Website Migration [26/09/2020]
Incident Report for BLE
Resolved
All migration has been completed.
Posted Sep 26, 2020 - 13:40 BST
Investigating
Our extended schedule of migration will be completed 26/09/2020 and the system will be inaccessible between 12pm and 2pm.
Posted Sep 25, 2020 - 16:18 BST
This incident affected: Learning Management System (Website).