Website Loading Speeds
Incident Report for BLE
Resolved
This incident has been resolved.
Posted May 13, 2020 - 13:59 BST
Investigating
We are currently looking into issues with the BLE taking longer than normal to load.
Posted May 13, 2020 - 13:43 BST
This incident affected: Learning Management System (Website).