iCloud Email Issues
Incident Report for BLE
Resolved
This incident has been resolved.
Posted Sep 06, 2020 - 13:43 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 06, 2020 - 13:42 BST
Update
We are continuing to investigate this issue.
Posted Sep 02, 2020 - 15:12 BST
Investigating
We're currently investigating iCloud emails bouncing when being sent. Please contact icloud to request the emails be marked as safe. If you have any questions please contact it@ble.support.

We are working to resolve the issues for future email accounts.
Posted Aug 19, 2020 - 12:33 BST
This incident affected: Psittacus Systems Services (Email Hosting Services).